Thursday 7th January 2021

Essential Maintenance on letshostbilling.com, scheduled 2 weeks ago

In order to carry out some essential systems upgrades, our server 'letshostbilling.com' will be offline. This maintenance will start at 21:00 on 07/01/2021 and will last approx. 90 minutes.

During this time, placing new orders on our website will not be possible, and access to the client area will be restricted. We apologise in advance for any inconvenience this may cause.

We will update this status message again at 22:00.

UPDATE 22:00 Maintenance is still ongoing and taking longer than expected. We expect to have everything fully functioning by 00:00

UPDATE 23:10 All maintenance has been completed