Thursday 27th May 2021

Scheduled Network Upgrades, scheduled 2 weeks ago

Update 23:43, 03/06/2021

Maintenance is complete, all systems are fully functional at this point. If you have any questions on these upgrades, please submit a ticket via your client area (https://www.letshostbilling.com/clientarea.php) and a member of our Support Dept. will be happy to advise from there.

Update 10:36, 03/06/2021 We are currently working on our network upgrades. We will update this status as the upgrades are carried out. If you have any questions on these upgrades, please submit a ticket via your client area (https://www.letshostbilling.com/clientarea.php) and a member of our Support Dept. will be happy to advise from there.

Update 17:50, 03/06/2021: Scheduled network upgrades are proceeding tonight as planned. We will update this status as the upgrades are carried out. If you have any questions on these upgrades, please submit a ticket via your client area (https://www.letshostbilling.com/clientarea.php) and a member of our Support Dept. will be happy to advise from there.

Update 19:11, 01/06/2021: This scheduled maintenance has been postponed until 03/06/2021. We will update this status again on Thursday evening.

On Tuesday 1st June, we have scheduled some network upgrades. This upgrade will affect all servers on IP range 78.137.164.x. The scheduled window for these upgrades is from 22:00 (01/06) until 02:00 (02/06).

We will update this status again closer to the upgrade window with more details.