Tuesday 27th February 2024

Scheduled Maintenance - Data Centre Upgrades, scheduled 5 months ago

Update 01:42 - Service has now been restored to the three affected servers: lh27.dnsireland.com , lh28.dnsireland.com and lh67.dnsireland.com

If you are having any issues connecting to LetsHost services please lodge a ticket on https://www.letshostbilling.com/submitticket.php or email us directly on support@letshost.ie


Update 01:28 - We are reviewing in relation to network issue currently affecting 3 servers after maintenance work and working to restore service as soon as possible. Affected servers are: lh27.dnsireland.com , lh28.dnsireland.com and lh67.dnsireland.com - we will post further information in 20 minutes and/or once anything available. We hope to restore service as soon as possible to these affected servers.

Update 00:57 - Service has now been fully restored. We are experiencing delays with our client area on https://www.letshostbilling.com/clientarea.php however we anticipate performance degredation to reduce over next 24 hours. If you are having any issues connecting to LetsHost services please lodge a ticket on https://www.letshostbilling.com/submitticket.php or email us directly on support@letshost.ie

Update 00:45 - More servers are coming back online but we are continuing to restore service. Work is ongoing and we will update this status page again in due course.

Update 00:02 - The majority of servers affected by this scheduled maintenance are now back online, however service is still being restored for the few remaining servers. ETA extended to further 20-30 minutes however we hope to restore full service as soon as possible. We will continue to update this status page as further progress is made.


Update 23:26 - We are experiencing a delay with NFS attached to some servers for backup purposes and this has now been restored. Dependent servers are now being addressed and booted and we will continue to update however we anticipate 30-45 minutes ETA for remaining affected servers. We will update shortly on progress.

Update 23:01 - Some servers scheduled to be offline are being powered on and network restored/online with service gradually being restored to affected servers. ETA and further details will be posted shortly.

Update 22:35 - Scheduled shutdown and data centre maintenance is underway. Further updates will be posted.


On Tuesday 27/02/2024, some scheduled maintenance will be carried out at our data centre. The scheduled maintenance window is 21:30-22:30, but we expect any downtime for individual servers to last 30 minutes or less.

While we appreciate this scheduled maintenance might be inconvenient for you, these works are required to upgrade some essential power systems and networking equipment at the data centre. Minimising disruption to customers will be a top priority during this time.

If you require any further information on this scheduled maintenance, please feel free to open a ticket via your client area. Our engineers will be updating this status page during the maintenance window to keep you informed on the night.