Wednesday 10th July 2024

Shared Servers Shared Server Outage

We're currently investigating an issue with one of our shared servers, win2.dnsireland.com/92.51.242.128. Our engineers are currently investigating this as their top priority.

We will update this status in 40 minutes (10:30). We apologise for any disruption this may cause you.

Update 10:30 - The server is back online however we are still waiting for some services such as IMAP to come fully back online, we will continue to monitor the situation and will provide a further update in 1hour (11:30)

Update 11:30 - Everything is back online now and apologies for any inconvenience caused, should you require any further assistance however please let us know by opening a support ticket from your Client Area: https://www.letshostbilling.com/clientarea.php and we can assist you further.