We're currently investigating an issue with some of our hypervisors, this has impacted some of our shared servers for lh16, lh19 and lh36. Our engineers are currently investigating this as their top priority.
We will update this status in 30 minutes (13:40). We apologise for any disruption this may cause you.
Update 13:30 - The hypervisor rebooted but some of the servers did not automatically come back online we, manually rebooted the individual servers and they should come back online shortly (15-20 minutes)
Update 13:40 - the servers are now back online, if you are still having any outstanding issues however please let us know by opening a ticket with our support team from your client area: https://www.letshostbilling.com/clientarea.php