We're currently investigating an issue with one of our shared servers, lh58.dnsireland.com/185.43.232.190. Our engineers are currently investigating this as their top priority.
We will update this status in 30 minutes (16:55). We apologise for any disruption this may cause you.
Update at 16:59 - we are continuing to work on this server, progress has been made and we expect to be back to full service soon.
Update at 18:29 - The situation should be now resolved.